Prerequisites for Linux

All you need is Python and pip installed, in order to install supervisely properly.

Note

If you already have Python and pip installed, you can skip step 3. Recommended version: Python 3.8

Option 1: Pure Python

  1. Update package manager.

apt-get update
  1. Install libjpeg-dev, libpng-dev, software-properties-common and ffmpeg utilities.

apt-get install -y --no-install-recommends libjpeg-dev libpng-dev software-properties-common ffmpeg
add-apt-repository universe
  1. Install Python.

apt-get install -y python3.8 python3-pip
update-alternatives --install /usr/bin/pip pip /usr/bin/pip3 1
update-alternatives --install /usr/bin/python python /usr/bin/python3 1

Option 2: Miniconda

  1. Update package manager.

apt-get update
  1. Install git and other utilities. They will be needed later.

apt-get install -y git curl ffmpeg
  1. Install Miniconda.

mkdir -p ~/temp
curl -sSL https://repo.anaconda.com/miniconda/Miniconda3-py38_4.8.3-Linux-x86_64.sh -o ~/temp/miniconda.sh
sudo bash ~/temp/miniconda.sh -bfp /usr/local
conda install -y python=3.8
conda clean --all --yes
rm -rf ~/temp/miniconda.sh